use strict;
my $str = 'alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS';
my $regex = qr/\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b/mxup;
my $subst = '${abrev}${roman}\\L${prep}\\E\\U${first}\\L${rest}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";