// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mxu)\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b").unwrap();
let string = "alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS";
let substitution = "${abrev}${roman}\\L${prep}\\E\\U${first}\\L${rest}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}