re = /\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b/mx
str = 'alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS'
subst = '${abrev}${roman}\\L${prep}\\E\\U${first}\\L${rest}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result