const regex = /\b
(
(?<abrev>(?:[A-Z]\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\w)(?<rest>\w+)
)
\b/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b
(
(?<abrev>(?:[A-Z]\\.)+)
|(?<roman>M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))
|(?<prep>(?i)d?[aoe]s?(?-i))
|(?<first>\\w)(?<rest>\\w+)
)
\\b', 'gmu')
const str = `alto dO cruzeiro
joão paulo II
N.S. aparecida
N.S. DAS GRAÇAS`;
const subst = `${abrev}${roman}\L${prep}\E\U${first}\L${rest}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);