# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sm)^[^\n]+(?=\r?\nflimflam)/new stuff/gm;t' <<< "foobar
blahblah
flimflam
zimzam
blahblah
zimzam"