using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)^[^\n]+(?=\r?\nflimflam)";
string substitution = @"new stuff";
string input = @"foobar
blahblah
flimflam
zimzam
blahblah
zimzam";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}