#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?sm)^[^\n]+(?=\r?\nflimflam)"
Local $sString = "foobar" & @CRLF & _
"blahblah" & @CRLF & _
"flimflam" & @CRLF & _
"zimzam" & @CRLF & _
"blahblah" & @CRLF & _
"zimzam"
Local $sSubst = "new stuff"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)