$re = '/(?sm)^[^\n]+(?=\r?\nflimflam)/m';
$str = 'foobar
blahblah
flimflam
zimzam
blahblah
zimzam';
$subst = "new stuff";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;