import Foundation
let pattern = #"(?sm)^[^\n]+(?=\r?\nflimflam)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foobar
blahblah
flimflam
zimzam
blahblah
zimzam
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"new stuff"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)