const regex = /(?sm)^[^\n]+(?=\r?\nflimflam)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?sm)^[^\\n]+(?=\\r?\\nflimflam)', 'gm')
const str = `foobar
blahblah
flimflam
zimzam
blahblah
zimzam`;
const subst = `new stuff`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);