use strict;
my $str = 'foobar
blahblah
flimflam
zimzam
blahblah
zimzam';
my $regex = qr/(?sm)^[^\n]+(?=\r?\nflimflam)/mp;
my $subst = 'new stuff';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";