re = /(?sm)^[^\n]+(?=\r?\nflimflam)/m
str = 'foobar
blahblah
flimflam
zimzam
blahblah
zimzam'
subst = 'new stuff'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result