import re
regex = re.compile(r"(?sm)^[^\n]+(?=\r?\nflimflam)", flags=re.MULTILINE)
test_str = ("foobar\n"
"blahblah\n"
"flimflam\n"
"zimzam\n"
"blahblah\n"
"zimzam")
subst = "new stuff"
result = regex.sub(subst, test_str)
if result:
print(result)