# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/href="(?!(?:\\/|https?))/\0\//gm;t' <<< "href=\"sdfsd
href=\"/sdcs
href=\"//svs
href=\"http:
href=\"https:"