re = /href="(?!(?:\/|https?))/m
str = 'href="sdfsd
href="/sdcs
href="//svs
href="http:
href="https:'
subst = '\\0/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result