$re = '/href="(?!(?:\/|https?))/m';
$str = 'href="sdfsd
href="/sdcs
href="//svs
href="http:
href="https:';
$subst = "\0/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;