const regex = /href="(?!(?:\/|https?))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(?!(?:\\\/|https?))', 'gm')
const str = `href="sdfsd
href="/sdcs
href="//svs
href="http:
href="https:`;
const subst = `\0/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);