import Foundation
let pattern = #"href="(?!(?:\/|https?))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
href="sdfsd
href="/sdcs
href="//svs
href="http:
href="https:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\0/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)