import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(?!(?:\\/|https?))";
final String string = "href=\"sdfsd\n"
+ "href=\"/sdcs\n"
+ "href=\"//svs\n"
+ "href=\"http:\n"
+ "href=\"https:";
final String subst = "\\0/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}