import re
regex = re.compile(r"href=\"(?!(?:\/|https?))", flags=re.MULTILINE)
test_str = ("href=\"sdfsd\n"
"href=\"/sdcs\n"
"href=\"//svs\n"
"href=\"http:\n"
"href=\"https:")
subst = "\\0/"
result = regex.sub(subst, test_str)
if result:
print(result)