#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<[^>]*)(USERNAME)([^>]*>)"
Local $sString = "foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo" & @CRLF & _
"" & @CRLF & _
"<!--:USERNAME-->" & @CRLF & _
"" & @CRLF & _
"<!-- eueuteh -->" & @CRLF & _
"" & @CRLF & _
" -DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> "
Local $sSubst = "test"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)