import Foundation
let pattern = #"(<[^>]*)(USERNAME)([^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY -->
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"test"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)