import re
regex = re.compile(r"(<[^>]*)(USERNAME)([^>]*>)")
test_str = ("foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo\n\n"
"<!--:USERNAME-->\n\n"
"<!-- eueuteh -->\n\n"
" -DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> ")
subst = "test"
result = regex.sub(subst, test_str)
if result:
print(result)