const regex = /(<[^>]*)(USERNAME)([^>]*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<[^>]*)(USERNAME)([^>]*>)', 'g')
const str = `foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> `;
const subst = `test`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);