package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<[^>]*)(USERNAME)([^>]*>)`)
var str = `foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> `
var substitution = "test"
fmt.Println(re.ReplaceAllString(str, substitution))
}