import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<[^>]*)(USERNAME)([^>]*>)";
final String string = "foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo\n\n"
+ "<!--:USERNAME-->\n\n"
+ "<!-- eueuteh -->\n\n"
+ " -DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> ";
final String subst = "test";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}