$re = '/(<[^>]*)(USERNAME)([^>]*>)/';
$str = 'foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> ';
$subst = "test";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;