// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<[^>]*)(USERNAME)([^>]*>)").unwrap();
let string = "foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> ";
let substitution = "test";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}