re = /(<[^>]*)(USERNAME)([^>]*>)/
str = 'foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> '
subst = 'test'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result