use strict;
my $str = 'foo bar baz <!-- USERNAME --> <!-- ACCESS_KEY --> baz bar foo
<!--:USERNAME-->
<!-- eueuteh -->
-DarchetypeVersion=<!-- java-version --> -UserName=<!-- :USERNAME --> -DsauceAccessKey=<!-- ACCESS_KEY --> ';
my $regex = qr/(<[^>]*)(USERNAME)([^>]*>)/p;
my $subst = 'test';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";