using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})";
string substitution = @"$0 AS $1";
string input = @" fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}