// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})").unwrap();
let string = " fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date";
let substitution = "$0 AS $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}