use strict;
my $str = ' fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date';
my $regex = qr/[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})/p;
my $subst = '$0 AS $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";