import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z\\.]{1,128}\\.([a-zA-Z\\_]{1,})";
final String string = " fs.id as swid,\n"
+ " maxgames.type_id,\n"
+ " maxgames.game.game_id,\n"
+ " maxgames.game.game_name,\n"
+ " maxgames.entry_id,\n"
+ " maxgames.entry_nickname,\n"
+ " maxgames.season_id,\n"
+ " maxgames.groups,\n"
+ " maxgames.rank,\n"
+ " maxgames.sort_global,\n"
+ " maxgames.points,\n"
+ " maxgames.create_date,\n"
+ " maxgames.last_update,\n"
+ " fs.year,\n"
+ " fs.month,\n"
+ " fs.date";
final String subst = "$0 AS $1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}