package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})`)
var str = ` fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date`
var substitution = "$0 AS $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}