re = /[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})/
str = ' fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date'
subst = '$0 AS $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result