# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})"
test_str = (" fs.id as swid,\n"
" maxgames.type_id,\n"
" maxgames.game.game_id,\n"
" maxgames.game.game_name,\n"
" maxgames.entry_id,\n"
" maxgames.entry_nickname,\n"
" maxgames.season_id,\n"
" maxgames.groups,\n"
" maxgames.rank,\n"
" maxgames.sort_global,\n"
" maxgames.points,\n"
" maxgames.create_date,\n"
" maxgames.last_update,\n"
" fs.year,\n"
" fs.month,\n"
" fs.date")
subst = "$0 AS $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.