# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)(\d{3})(?!\d)/,$1/g;t' <<< "100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
"