import re
regex = re.compile(r"(?<=\d)(\d{3})(?!\d)")
test_str = ("100000\n"
"?100000?50000\n"
"X10000.5?\n\n"
"100,000\n\n"
"123456789\n"
"1.9876\n")
subst = ",$1"
result = regex.sub(subst, test_str)
if result:
print(result)