re = /(?<=\d)(\d{3})(?!\d)/
str = '100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
'
subst = ',$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result