import Foundation
let pattern = #"(?<=\d)(\d{3})(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #",$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)