import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d)(\\d{3})(?!\\d)";
final String string = "100000\n"
+ "?100000?50000\n"
+ "X10000.5?\n\n"
+ "100,000\n\n"
+ "123456789\n"
+ "1.9876\n";
final String subst = ",$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}