const regex = new RegExp('(?<=\\d)(\\d{3})(?!\\d)', 'g')
const str = `100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
`;
const subst = `,$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);