use strict;
my $str = '100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
';
my $regex = qr/(?<=\d)(\d{3})(?!\d)/p;
my $subst = ',$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";