# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<FORMAT=T>(\d+)<\/FORMAT>/\1/gm;t' <<< "<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>"