// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<FORMAT=T>(\d+)</FORMAT>").unwrap();
let string = "<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}