re = /<FORMAT=T>(\d+)<\/FORMAT>/m
str = '<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result