import Foundation
let pattern = #"<FORMAT=T>(\d+)</FORMAT>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)