import re
regex = re.compile(r"<FORMAT=T>(\d+)</FORMAT>", flags=re.MULTILINE)
test_str = "<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)