# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\d,])\x22\d+(,)\d+\x22//gm;t' <<< "98,52,\"110,18479456000019\"
98809797,9880979752,\"110,18479456000019\""